Older iMac OS
Posted: 15 April 2020 03:42 PM  
Member
Rank
Total Posts:  1
Joined  2020-04-13

I have a six year old iMac running OS 10.10.5.  This is the latest OS I can run on my iMac. But your ICC application for Mac needs 10.13 or later to run.

Is there an older version of the ICC APP that I can run on my iMac?

Gorman

Profile